通达信震荡高抛低吸指标公式

2020-04-11 14:47:28
分享到:

M2:=36;

P:=13;

M:=5;

SHORT:=21;

LONG:=44;

MIDD:=11;

P1:=11;

DF:=3;

N1:=12;

RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;

K:=SMA(RSV,DF,1);

D:=SMA(K,DF,1);

KK:=SMA(RSV,DF,1);

DD:=SMA(K,DF,1);

N:=KK+DD;

关注区:STICKLINE(N<50,N,50,2,0),COLORRED;

风险区:STICKLINE(N>160,N,160,2,0),COLORGREEN;

成本区:50,COLORYELLOW,LINETHICK2;

GWGD:=N<REF(N,1) AND REF(N,1)>=160 AND REF(N,1)>=REF(N,2);

获利区:160,COLOR007700,LINETHICK2;

操盘线:N,COLORFF00FF,LINETHICK1;

买:DRAWICON(CROSS(N,50),50,26),COLORRED;

卖:DRAWICON(CROSS(160,N),160,15),COLORGREEN;

AA:=(C+O+L+H)/4;{以下含未来,不喜删除}

BB:=REF(CLOSE,AA);

获利盘:=SMA(MAX(CLOSE-BB,0),2,1)/SMA(ABS(CLOSE-BB),2,1)*100;

DZ1:=获利盘>REF(获利盘,1) AND 获利盘>89;

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

CCI1:=EMA(EMA(EMA(CCI,2),2),2);

CCI2:=EMA(EMA(EMA(CCI,3),2),2);

DZ2:=CCI1>100;

T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;

SL:=(T/REF(T,1)-1)*1000;

快:=XMA(XMA(XMA(SL,3),3),3);

慢:=XMA(XMA(XMA(SL,5),5),5);

X:=快-慢;

增速1:=X;

WWW:=REF(增速1,1)<0;

DZ4:=增速1>3 AND WWW;

选股:=DZ1 AND DZ2 AND DZ4;

STICKLINE(选股,50,150,2,0),COLORYELLOW;

DRAWTEXT(选股,120,'*暴涨'),COLORRED;

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。不构成任何投资建议,据此操作,风险自担。