通达信更好看盘指标公式

2020-04-11 14:47:31
分享到:

X:=C-REF(MA(C,20),11);

LL:=EMA(C,5)/EMA(EMA(C,9),16)*100-100;

底域:IF(REF(LL<-4,1),1,0),COLORLIGRAY,NODRAW;

W1:=-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))+100*X;

W2:=-100*(HHV(H,50)-C)/(HHV(H,50)-LLV(L,50))+100;

W3:=-100*(HHV(H,70)-C)/(HHV(H,70)-LLV(L,70))+100*X;

B1:=((C-MA(C,34))/MA(C,34)*100+10)*5;

B2:=((C-MA(C,50))/MA(C,50)*100+10)*5;

B3:=((C-MA(C,70))/MA(C,70)*100+10)*5;

BII:=(C-MA(C,6))/MA(C,6)*200,COLORGREEN;

S1:=(W1+W2+W3+B1+B2+B3)/6*X;

SS:(W1+W2+W3+B1+B2+B3)/6,COLORMAGENTA;

MS:MA(SS,3),COLORYELLOW;

底买:底域=1 AND CROSS(LL,REF(LL,1))OR(REF(底域=1,1)AND 底域=0 AND SS<0.5),COLORRED,NODRAW;

YY:=SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,18,1),12,1);

YT:=SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,12,1);

减仓:IF(CROSS(YT,YY),30,0)COLORLICYAN,STICK;

T:=(H+L+C)/3;

PT:=(T-MA(T,14))/(0.015*AVEDEV(T,14));

VT:=(T-MA(T,85))/(0.015*AVEDEV(T,85));

出局:IF(VT>=200 AND PT>=150,20,0),STICK,COLORCYAN,LINETHICK2;

RS1:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;

SM:=IF(RS1>75 OR REF(RS1>80,1),30,0);

{股旁网-股票指标公式网 www.gupang.com}

卖点:IF(SM=30 AND (出局=20 OR 减仓=30),30,0),COLORGRAY;

双金叉:CROSS(SS,0)AND CROSS(BII,-0.5),COLORYELLOW,NODRAW;

低金叉:REF(SS<-50,1)AND CROSS(SS,REF(SS,1)),COLOR0088FF,NODRAW;

底启:REF(SS<0,1)AND CROSS(SS,MS)AND CROSS(BII,0),COLORWHITE,NODRAW;

筹码:=WINNER(C)*100,NODRAW;

买:REF(筹码,1)<REF(筹码,2)AND 筹码>REF(筹码,1)AND C>=O AND REF("KDJ.J"<45,1),COLORLIRED,NODRAW;

卖:REF(筹码,1)>REF(筹码,2)AND 筹码<REF(筹码,1)AND REF("KDJ.J">75,1),COLORCYAN,NODRAW;

ATR:=MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1)));

DMZ:=IF((H+L)<=(REF(H,1)+REF(L,1)),0,ATR);

DMF:=IF((H+L)>=(REF(H,1)+REF(L,1)),0,ATR);

DIZ:=SUM(DMZ,13)/(SUM(DMZ,13)+SUM(DMF,13));

DIF:=SUM(DMF,13)/(SUM(DMF,13)+SUM(DMZ,13));

波值:=DIZ-DIF;

短势:=SMA(波值,30,10);

中势:=MA(短势,5);

势金:CROSS(短势,中势)*10,COLORLIMAGENTA,STICK,LINETHICK2;

STICKLINE(买=1,0,5,1,0),COLORLIRED;

STICKLINE(卖=1,0,-3,1,0),COLORCYAN;

DRAWTEXT(买=1,6,' 买'),COLORLIRED;

STICKLINE(双金叉=1,0,25,0.1,0),COLORYELLOW;

DRAWTEXT(低金叉=1,SS*0.8,'低金'),COLOR0088FF;

STICKLINE(低金叉=1,SS,SS*0.8,0.1,0),COLOR0088FF;

STICKLINE(底启=1,-5,10,0.1,0),COLORWHITE;

STICKLINE(底域=1,-15,-18,1,0),COLORWHITE;

STICKLINE(底买=1,-20,-15,1,0),COLORRED;

DRAWICON(SS-REF(MS,1)<-25,SS,1);

DRAWICON(FILTER(SS-REF(MS,1)>23,2),SS,2);

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。不构成任何投资建议,据此操作,风险自担。