通达信看似明白指标公式

2020-04-11 14:47:40
分享到:

月初:=DAY<REF(DAY,1),NODRAW;

月未:=REFX(DAY<REF(DAY,1),1),NODRAW;

下次月未:=BARSNEXT(月未=1);

月交易天数:1+BARSLAST(BARSCOUNT(C)=0 OR 月初!=0),COLORYELLOW,NODRAW;

月开盘:REF(O,月交易天数-1),COLORWHITE,NODRAW;

月最高:MAX(HHV(H,月交易天数),REFX(HHV(H,月交易天数+下次月未),下次月未)),COLORLIMAGENTA,NODRAW;

月最低:MIN(LLV(L,月交易天数),REFX(LLV(L,月交易天数+下次月未),下次月未)),COLORLIGREEN,NODRAW;

月收盘:REFX(C,下次月未),NODRAW;

月涨:= 月开盘<=月收盘,NODRAW;

月跌:= 月开盘>=月收盘,NODRAW;

STICKLINE(月涨, 月最高,月最低,3,1),COLORBROWN;

STICKLINE(月跌,月最高,月最低,3,1),COLORLIBLUE;

周初:=WEEKDAY-REF(WEEKDAY,1)!=1;

周交易天数:1+BARSLAST(周初 ),NODRAW;

RR:=BACKSET(周交易天数<REF(周交易天数,1),2),NODRAW;

周未:=( RR=1 AND 周交易天数!=1) OR WEEKDAY=5 ,NODRAW;

下次周未:=BARSNEXT(周未=1);

周最高:MAX(HHV(H,周交易天数),REFX(HHV(H,周交易天数+下次周未),下次周未)),NODRAW;

周最低:MIN(LLV(L,周交易天数),REFX(LLV(L,周交易天数+下次周未),下次周未)),NODRAW;

周开盘:REF(O,周交易天数-1),NODRAW;

周收价:REFX(C,下次周未),NODRAW;

周涨:= 周开盘<=周收价;

周跌:= 周开盘>=周收价;

STICKLINE(周涨,周最高,周最低,3,0),COLORMAGENTA;

STICKLINE(周跌,周最高,周最低,3,0),COLORFF2400;

STICKLINE(C>=O,H,C,0,0),COLOR225588;

STICKLINE(C>=O,H,C,0,0),COLOR66CCFF;

STICKLINE(C>=O,O,L,0,0),COLOR225588;

STICKLINE(C>=O,O,L,0,0),COLOR66CCFF;

STICKLINE(C>O,C,O,3.4,0),COLOR225588;

STICKLINE(C>O,C,O,3.0,0),COLOR226699;

STICKLINE(C>O,C,O,2.4,0),COLOR3377AA;

STICKLINE(C>O,C,O,2.0,0),COLOR3388BB;

STICKLINE(C>O,C,O,1.6,0),COLOR4499CC;

STICKLINE(C>O,C,O,1.2,0),COLOR44AADD;

STICKLINE(C>O,C,O,0.6,0),COLOR55BBEE;

STICKLINE(C>O,C,O,0.1,0),COLOR66CCFF;

STICKLINE(C<=O,H,C,0,0),COLOR888800;

STICKLINE(C<=O,H,C,0,0),COLORFFFF00;

STICKLINE(C<=O,O,L,0,0),COLOR888800;

STICKLINE(C<=O,O,L,0,0),COLORFFFF00;

STICKLINE(C<=O,C,O,3.4,0),COLOR888800;

STICKLINE(C<=O,C,O,3.0,0),COLOR999900;

STICKLINE(C<=O,C,O,2.4,0),COLORAAAA00;

STICKLINE(C<=O,C,O,2.0,0),COLORBBBB00;

STICKLINE(C<=O,C,O,1.6,0),COLORCCCC00;

STICKLINE(C<=O,C,O,1.2,0),COLORDDDD00;

STICKLINE(C<=O,C,O,0.6,0),COLOREEEE00;

STICKLINE(C<=O,C,O,0.1,0),COLORFFFF00;

周中价:(周最高-周最低)/2+周最低,COLORWHITE,NODRAW;

STICKLINE(周中价,周中价,周中价,2.5,0),COLORWHITE;

日中价:(H-L)/2+L,COLORWHITE,NODRAW;

STICKLINE(日中价,日中价,日中价,1,0),COLORBROWN;

郑重声明:东方财经网旨在传播互联网信息,该文观点仅代表作者本人,与本站无关。不构成任何投资建议,据此操作,风险自担。